ISSUE:

Emails from trusted sources are not showing up in the Outlook Inbox.


ROOT CAUSE:

The emails are blocked by the Barracuda Email Security Services.


SOLUTION:

Whitelist the emails from the Barracuda Email Security Services portal.


STEPS:


1: Login to the Barracuda Email Security Service portal. This link is under the Kemin Favorites or Bookmark.


2. Enter your Kemin Internet email address.


3. Key-in your Windows password.



4. The Barracuda Email Security Service Window will show up.



5. Set Message Filter to Not Allowed.


6. Set the days as per your criteria. In this example, we are looking for Blocked email for the last 2 days.



7. Tick the box for the email that you want to be forwarded to your MS Outlook Inbox.


NOTE:

Please ensure that you only allow emails from trusted source. Otherwise, phishing, spam & infected emailsĀ may get through your MS Outlook Inbox.


8. Click Whitelist.


9. You will see a message that the blocked emails are queued for release.



10. Change the Message Filter to see the Allowed emails.


11. This view tells that the block emails were now released.


12. Logout of the Barracuda Email Security Service.


13. Go to your MS Outlook and check the released emails by the Barracuda Email Security Service.