ISSUE:

Still not able to receive email messages in Outlook Inbox even after allowing the valid emails for delivery in Barracuda Email Security (BESS).

 

ROOT CAUSE:

Spam filters detect unsolicited, unwanted, and virus-infested email (called spam) and stop it from getting into email inboxes. Spam filters block threats, filter legitimate emails, meet data regulations & & protect business reputation. Junk Email is the folder where Outlook sends mail it thinks is spam. The blocked emails may likely be in the Junk folder.

 

SOLUTION:

The fix is to go to the Outlook Junk folder, search for the blocked valid emails & tag the emails as Not Junk.